Installation et configuration d’openelec sur le Raspberry-PI

openelec

OpenElec est une distribution Linux basée sur XBMC, un média center (Linux, Mac OSX et Windows) très connu. Son gros avantage c’est qu’il supporte nativement de nombreux formats vidéos, audio et images.

Grâce à celui-ci, vous pourrez lire des fichiers vidéos même encodés en HD 1080p. Il existe plusieurs façons de disposer d’XBMC sur son raspberry Pi comme la version RaspBMC ou encore l’installation “manuel” d’XBMC sur Raspbian.

Clipboard_Full PRE-REQUIS

Matériels :

Logiciel :

Installation d’OpenElec

Nous allons maintenant installer la distribution OpenElec sur le RPI. Tout d’abord Il faut installer l’OS choisi sur la carte SD par le lien spécifié dans les Pre-requis. Télécharger la dernière image d’OpenElec par le lien fourni dans les prérequis. Une fois le téléchargement terminé, procéder comme suit.

Lancez Win32 Disk Imager et sélectionner l’image d’OpenElec puis cliquez sur “Write” :

installoe

Win32 Disk Imager > Raspbian

Configuration d’XBMC

Un fois le téléchargement et l’installation automatique terminé, placer la carte SD dans votre Raspberry-PI. Branchez votre câble vidéo, votre clavier, puis le câble Ethernet. Terminez toujours par le branchement de l’alimentation. Voila à quoi devrait ressembler votre menu au premier démarrage :

screenxbmc

Menu d’openelec

Tout d’abord allons configurer les réglages systèmes :
– Langages en français :
Systèm → settings → Appearance → International.

– Etalonnage de l’écran :
Système → Paramètre → Système → Sortie vidéo → Etalonnage.

– Clavier en Fr – AZERTY :
Système → OpenELEC → Clavier.

Voila pour les modifications côté systèmes. Je vous laisse jeter un coup d’oeil pour un paramétrage plus spécifique comme la gestion de l’audio.

Maintenant que nous avons configuré les réglages systèmes, configurons notre médiathèque. Dans mon cas, j’accède à mes films et séries depuis mon NAS Synology. De multitudes méthodes d’accès sont évidemment disponible. Afin de gérer facilement les affiches, je vous conseille de les gérer de la façon suivante :

Films :
Créer un dossier “Films” et dans ce dossier créer un dossier par films avec le média à l’intérieur. De cette façon si vous récupérez le film en meilleure qualité par exemple il vous suffira de remplacer le fichier.

Exemple : Films → Drive → Drive.avi

SérieTV :
Créer un dossier TV Shows” et dans ce dossier créer un dossier par Série puis dans ce dossier des dossiers par saison avec les média à l’intérieur.

Exemple : TV Shows → Mad Men → Saison 1 → episodes1x01.avi

[encart coul= »error »]pour les séries la notation “1×01” en fin de fichier est importante pour chaque épisode. Cela permet de récupérer correctement les informations de chaque épisode.[/encart]

Une fois fois l’actualisation de vos dossiers réalisés, passons à la configuration de la médiathèque.

On configure le chemin des médias.

Vidéo → Fichiers → Clic sur “Ajouter une source vidéo” Spécifier comme nom « Films » et cliquer sur “parcourir”.

Sélectionnez maintenant l’endroit ou se situent vos films et validé avec OK. Maintenant, il faut choisir le Scraper « TheMovieDB » adapté pour les films, afin d’avoir les affiches.

films

Vidéo > Fichiers > Films

Cocher « Exécuter le scan automatiquement » ainsi que « consultation avec les noms des dossiers » puis modifier les « paramètres » à votre gout en cliquant sur le bouton du même nom. Valider et les affiches se téléchargeront automatiquement.

Si vous accéder à un NAS n’oublier pas d’enregistrer les identifiants de connexion en cliquant sur “ajouter un chemin” puis de choisi le protocole “SMB”.

Pour les séries TV il vous suffit de suivre le chemin suivant :

Vidéo → Fichiers → Clic droit sur“TV Shows”puis cliquez sur“Editer cette source”.

Sélectionnez maintenant l’endroit ou se situent vos Séries TV. Une fois validé choisir le scraper « The TVDB » pour le téléchargement des affiches.

série

Vidéo > Fichiers > TV Shows

Cocher « Exécuter le scan automatiquement » puis modifier les « paramètres » comme précédemment pour les films.

Voilà la configuration de la médiathèque et terminée.

Télécommande XBMC

Il existe de nombreuses façon de diriger son média-center XBMC. quelques modèles chez amazon.

Clavier Sans-Fil

Personnellement j’utilise le clavier sans-fil Logitech K400. Ce clavier est vraiment excellent pour contrôle votre media-center. De plus il est détectable directement par OpenElec et Raspbmc.

Clavier Logitech K400

Smartphone Android

Yatse se configure facilement car il recherche automatiquement XBMC.

Paramétrages pour utiliser Yatse

Voici les paramètres à modifier pour contrôler votre média-center depuis sur portable Android :

Depuis XBMC

Modifier tout d’abord vos paramètres réseaux en « Statique ». Exemple :

Programmes → Openelec → réseau→ Adresse IP  :

– Network mode :Wired Netword

– IP address : 192.168.1.10

– Subnet Mask : 255.255.255.0 (24)

– Gateway : 192.168.1.1

les informations de paramétrages réseau sont ici à titre indicatif. vous pouvez trouver l’ensemble des informations en vous connectant sur votre Box Internet.

Maintenant on configure l’accès depuis les paramètres systèmes :

Systèmes → Servives → Général → Nom du dispositif : XBMC(choix du nom de votre média-center).

Systèmes → Servives → Upnp → Cocher les « 3 choix ».

Systèmes → Servives → Serveur Web → Cocher « permettre le contrôle de XBMC en HTTP »puis configurer les paramètres suivants :

– Port : 8080

– Nom d’utilisateur et mot de passe : Identifiants et mot de passe de votre choix.

Par défaut « xbmc », vous pouvez bien évidemment garder « xbmc » comme identifiant et laisser le mot de passe vide.

Systèmes → Servives → Télécommande → cocher les « 2 choix ».

Systèmes → Servives → Zeroconf → Vérifier bien que la case soit également cocher.

Depuis Yatse

Installer l’applications sur votre smartphone depuis le store ou le lien présent sur l’icone précédente.

Lancer l’applications puis cliquez sur « paramètres » et« gérer »puis  » + « .Yatse devrait maintenant chercher XBMC.

Une fois votre média-center trouvé, il ne vous reste qu’à configurer les paramètres comme sur XBMC.

Et voila pour le contrôle depuis votre canapé ! 😉

N’hésitez pas à me faire part de vos retours sur des erreurs ou autres questions ! à très vite 🙂

Si vous êtes intéressé par cette solution, je vous conseille de la « coupler » avec un NAS Synology ! Grâce à ce type de matériel, vous allez pouvoir stocker l’ensemble de vos fichiers médias (Films, Séries, Musiques) sur le serveur NAS et lire de contenu efficacement sur votre TV avec votre Raspberry-Pi. En savoir plus…

IMPORTANT

Il se peut que votre Raspberry-Pi chauffe ou soit lent. Pour éviter ce problème, je vous conseille d’intégrer des dissipateurs à votre Raspberry-Pi. Ils sont très simples à mettre en place !

Voici le lien: Dissipateur thermique RPI

Partager l'article >Share on FacebookShare on Google+Tweet about this on TwitterShare on LinkedInEmail this to someone

28 Comments

  • gpe

    Reply Reply 10 mars 2013

    bonjour,

    J’ai aussi un K400 mais si effectivement il est bien détecté par contre le mapping du clavier est en qwerty au lieu d’azerty.
    Est-ce pareil pour vous ? Si non, comment avez-vous fait pour passer en azerty ?

    • Régis

      Régis

      Reply Reply 11 mars 2013

      Bonjour,

      En effet, j’ai également remarqué le problème sur Openelec! (je recherche et test des solutions, mais rien de concluant pour le moment).
      Actuellement je suis sur Raspbmc qui fonctionne parfaitement et sur lequel on peu passer facilement en AZERTY. Voici le lien pour l’installation et la configuration du clavier.

      Je vous tiens au courant si je trouve une solution pour openelec! 😉

  • Iznogoud

    Reply Reply 15 avril 2013

    J’ai le même problème !

    Voici un lien qui propose un contournement : http://passion-xbmc.org/openelec/clavier-toujours-en-qwerty/?wap2

  • florian

    Reply Reply 26 janvier 2014

    Bonjour j ai un ras Perry ou j ai installer openelec j ai un petit souci quand je regarde un film qui se situe sur un disque réseau sous smb au bout de 5 min j ai mon filme qui s arrêté est ce que que quelqu’un connait la raison et pourquoi… Comment corriger le problème.

    • Régis

      Régis

      Reply Reply 26 janvier 2014

      Salut! En effet, j’ai également noté des petits problèmes de ce genre sur Openelec.. Personnellement, je te conseil d’utiliser plutôt RaspBMC (tuto). Fonctionne parfaitement depuis plus de 1 ans chez moi! 😉

  • Thomas

    Reply Reply 24 mai 2014

    Bonjour,
    J’ai openelec(4.0.2) sur Raspberry et j’ai bien trier mes films comme dans l’article.
    Mes films sont sur un DD externe brancher en USB sur le Raspberry.
    Lorsque je vais dans Ajouter une source, je ne trouve pas mon DD est, vu qu’il est déjà afficher dans le sous menu « Fichier ». Et je n’arrive pas pas à me faire une médiathèque, simple d’utilisation, et je n’arrive pas non plus à scrapper ducoup.

    Une idée ? en espérant avoir été clair.

  • Thomas

    Reply Reply 24 mai 2014

    Je viens de trouver la réponse, excusez moi d »avoir poster pour rien.
    Mais pour la réponse , il faut aller dans ajouter une source –>racine–>media–> et la on retrouve le DD externe 🙂

    • Régis

      Régis

      Reply Reply 25 mai 2014

      Salut Thomas! aucun problème, au contraire ton avis peu servir à d’autre. 🙂
      A Bientôt.

  • Jir4

    Reply Reply 5 juillet 2014

    Petit ajout au niveau de la commande de xbmc, le raspeberry est capable de gérer le HDMI-CEC, si votre écran est compatible il devient alors possible de gérer tout à la télécommande, le pied quoi ^^(pour info les constructeur aime donné un autre nom au standard histoire de se faire mousser genre c’est moi qui l’ai inventé. Par exemple sur les écran samsung la techno s’appelle anynet+, il suffit de l’activer dans la config de l’écran et dans xbmc, plus d’info sur tout ça ici : http://wiki.xbmc.org/?title=CEC )

  • Jordan

    Reply Reply 14 octobre 2014

    bonjour a tous,
    Actuellement j’utilise Raspbmc sur un raspberry pi b+ mais j’ai un soucie ( vous vous en doutez puisque je suis la) lors du parametrage du mon scrapper de film j’ai fait oune bêtise ^^ j’aimerai modifier les paramètre du scrapper mais pas moyen je n’arrive pas à accéder à un menu adéquate

    Un avis ?

    Merci !!!!!

    • Régis

      Régis

      Reply Reply 14 octobre 2014

      Salut Jordan,
      Tu souhaite modifier le type de scrapper c’est bien ça? A quel endroit tu bloque exactement ?

      • Jordan

        Reply Reply 15 octobre 2014

        D’abord merci de ta réponse rapide ^^
        En fait je n’ai pas paramétré le scrapper correctement. mon DDE possède un fichier de film avec des titres en français sauf que mon scrapper recherche des titre anglais >_< et pas moyen de supprimer mon scrapper ou de trouver un menu contextuel permettant la modification des paramètres

        Encore merci

        • Régis

          Régis

          Reply Reply 15 octobre 2014

          Ok je vois ton problème ^^
          Le menu n’est pas très simple à trouver en effet.. Il faut que tu te place dans le menu suivant pour re-paramètrer le scrapper :
          Vidéo > Fichiers > Films (créé comme le tuto) > « Parcourir ».
          C’est à cet endroit que tu dois choisir le scrapper (TheMovieDB).

          Tiens moi au courant du résultat 😉

          • Jordan

            15 octobre 2014

            Je test ça se soir en rentrant du boulot et je te dit ce qu’il en est !!
            Merci en tout cas pour ta réactivité !!

  • Jordan

    Reply Reply 14 octobre 2014

    D’abord merci de ta réponse rapide ^^
    En fait je n’ai pas paramétré le scrapper correctement. mon DDE possède un fichier de film avec des titres en français sauf que mon scrapper recherche des titre anglais >_< et pas moyen de supprimer mon scrapper ou de trouver un menu contextuel permettant la modification des paramètres

    Encore merci

  • stef

    Reply Reply 6 mars 2015

    Bonjour j ai racheter un pi b+ avec sd de 32go class 10 avec kodi 5.05 d installer dessus,
    au premier branchement tout ok il me demande de tout parametrer . Francais, reseau ect…
    je mamuse un peu avec tout ok..
    j eteins kodi par le bouton off je debranche pi, et la premiere erreur il ne demarre pas
    je redebranche lalim qui est une alim usb de chargeur 2 A .. et la rebranche..
    le systeme redemarre sur kodi mais il faut tout reparametrer…
    ya til une solution?
    Merci de votre lecture et votre reponse eventuelle

    • Régis

      Régis

      Reply Reply 8 mars 2015

      Bonjour Stéphane,
      En effet, étonnant que ta carte SD ne garde pas tes paramètres.
      Comment a tu fait l’installation sur ta carte SD ? (carte pré-installé, RaspBmc, OpenElec ?)
      Peut-être qu’une réinstallation de la carte SD pourra résoudre ce problème.
      N’hésite pas à me tenir au courant !

  • xystius

    Reply Reply 17 mai 2015

    Bonjour

    Merci pour ce tuto !!

    J’ai crée un repertoire Cinema incluant 2 sous répertoires films et séries.
    Tout fonctionne parfaitement pour les films, mais le raspberry ne voit pas les séries.
    Il n’importe donc pas les info du scrapper…..( themoviesdb)
    sauf si je parcours les fichiers et ce depuis la Tv….

    QQ a une idée du pb ?

    • Régis

      Régis

      Reply Reply 17 mai 2015

      Bonjour,
      Je pense que le problème vient du fait que tu regroupes les séries et les films dans le même répertoire. Pour remonter les informations des sériesTv, l’application utilise un autre scrapper.

      Je te conseille donc de créer un répertoire « films » et un « sériesTV » bien distinct.
      Tu ne devrais dans ce cas avoir aucun problème pour remonter les informations. 🙂

      N’hésite pas à me faire un petit retour si tout est Ok! 😉

  • xystius

    Reply Reply 27 mai 2015

    Bonjour,
    Ton message du 17 mai nous a mis la puce à l’oreille.
    Certes, j’avais déja fais une séparation films/séries.
    Toutefois, j’avais ajouté une autre séparation public / public averti.
    Ce qui me permettait de resteindre les droit de lecture à mes enfants sur les répertoires concernés.

    Cinéma
    – Films
    — Tout public
    — Public averti
    -Séries
    — Tout public
    — Public averti

    Si ce fonctionnement ne gène pas pour les films, c’est cela qui bloquait les séries.
    En effet, il recherchait des séries nommés  » Tout public et public averti »

    J’ai donc supprimer ces deux sous répertoires, quitte à restreindre à chaque répertoire de series concernés.

    Puisse cet expérience servir à d’autre.

    Merci
    Xys’

  • xystius

    Reply Reply 6 juin 2015

    Bonjour,

    Je souhaiterais savoir si qq a deja rencontré le pb de  » histoire du cinema » .
    IL semblerait que bcp de series ne soit pas reconnu correctement et soient tous associés à cette séries française….

    Xys’

  • bruno_02

    Reply Reply 11 juin 2015

    Bonsoir toutes et tous.

    J’ai un Raspberry première version (RASPBERRY PI, MODEL B, 512MB)

    et je bloque sur la lecture de vidéo en HD sur youtube
    cela saccade et ça m’eneeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeerve
    que ce soit openelec ou autres distrib
    le nouveau Raspberry fait il mieux ?

    merci

    • Régis

      Régis

      Reply Reply 11 juin 2015

      Bonsoir Bruno,

      Les vidéos saccades seulement depuis Youtube ou également si tu lance des vidéos d’un Disque Dur ou d’un NAS ?

      • bruno_02

        Reply Reply 11 juin 2015

        en fait je regarde que you tube ………………….

        il faut que je teste sur mes dd

        merci d’ avoir répondu

        je te tiens au jus

  • bruno_02

    Reply Reply 12 juin 2015

    bonjour

    après test pas de blocage sur disque dur en passant par smb workgroop
    j’ai changé en mettant une sd hc rapide

    j’ai toujours ces blocages

    merci

    • Régis

      Régis

      Reply Reply 12 juin 2015

      Salut,

      Je t’avoue que personnellement, je n’utilise pas mon Raspberry pour lire des vidéos sur youtube. Je vais cependant essayé de faire le test quand je trouverai le temps est voir ce que ça donne.

      Du coup tu n’a pas de blocage avec un disque dur, mais tu en as avec une carte SD c’est bien ça ?

      En même temps je ne suis pas étonné, le Raspberry-Pi n’est pas vraiment optimisé pour lire du streaming en HD :/

  • bruno_02

    Reply Reply 12 juin 2015

    bonjour

    en fait il s’agit de la mémoire cache insuffisante pour executer tout le flux

    je ne sais pas si il y une solution

    merci en tous les cas d’avoir répondu

    bon week end

  • Ricco

    Reply Reply 25 novembre 2016

    Bjr,

    J’ai u raspberry Pi3, avec openelec.
    J’ai suivi bcp de tutos sur la config de la telecommande (Smartphone ou clavier Rii) mais impossible de démarrer mon openelec avec yatse ou Rii.
    Comment faire pour être sûr d’avoir bien paramétré son Rasp?
    La dernière réponse date de 2015 et je ne pense pas qu’on me réponde.
    Mais voilà l’info est lancée…
    C’est comme les IPTV, j’ai des sources IPTV de toutes les chaines française, Bing, canal et autres, mais je n’arrive pas à avoir le bouton TV sur mon OPenelec.

Leave A Response

* Denotes Required Field